Рассмотрим еще одно нестандартное использование функции ВПР.

Задача: Наиболее простым способом научиться указывать тот столбец, из которого функция ВПР будет извлекать данные. При этом мы не будем изменять саму формулу, поскольку это может привести к случайным ошибкам.

Итак, в нашем распоряжении таблица с товарами и различными видами цен на них. В зависимости от того, какой из показателей нам нужен, необходимо изменить номер столбца, из которого ВПР будет извлекать данные.

Данные, которые нас интересуют, находятся в столбцах G, H, I. В диапазоне A1:I7 они имеют номера 4, 5, 6. Как нам получить эти порядковые номера и как изменять их, не корректируя формулу ВПР?

Для этого нам пригодится функция ПОИСКПОЗ (MATCH). Она как раз то и возвращает номер определенного значения в диапазоне данных. Мы должны указать это значение в ячейке В1.

Для того, чтобы избежать ошибок при вводе, создадим выпадающий список в B1.

Как сделать выпадающий список в Excel? Читайте подробную инструкцию.

Получаем следующую картину:

Теперь мы гарантированно выберем нужный показатель: ошибки при вводе исключены.

Определить номер нужного столбца при помощи ПОИСКПОЗ можно так:

=ПОИСКПОЗ($B$1;$D$1:$I$1;0)

Поясним: мы ищем значение из В1 в диапазоне D1:I1 с точным совпадением.

Подставим эту формулу в функцию ВПР вместо параметра "номер столбца". Получим:

=ВПР(A2;$D$2:$I$7;ПОИСКПОЗ($B$1;$D$1:$I$1;0);0)

Вот как это выглядит:

как указать ВПР столбец, из которого извлекать данные

Скопируйте нашу формулу для всех товаров.

Теперь ВПР ищет нужное наименование товара в D и затем извлекает для него ту цену, которая выбрана в выпадающем списке в ячейке В1. Задача динамического изменения номера столбца с извлекаемыми данными решена.

4 способа, как сделать левый ВПР в Excel.

ошибки

Почему не работает ВПР в Excel?